Valheim - Dedicated Server Setup for Windows Using SteamCMD



Eric shows you how to set up your own dedicated server for Valheim. The Viking Survival game designed by Irongate AB and Published by @Coffee Stain . This is for Windows machines using SteamCMD.
Buy Windows Server 2016 for $115 off Amazon: https://amzn.to/2P4v8lF
IF this video helped you, please consider supporting us on Patreon, even the $1 is greatly appreciated https://www.patreon.com/Maturemindedgamers

How to Open Windows Firewall Ports: https://www.youtube.com/watch?v=gF_-Tu7g06Y&list=PLwnwmfk3tiMKYzDlg1PAHIapRcLTcE-nh&index=35&t=3s
Ports that Need Open: TCP/UDP 2456-2458
Steam Server ID: 896660
Join us at – http://www.maturemindedgamers.com

49 thoughts on “Valheim – Dedicated Server Setup for Windows Using SteamCMD”
  1. So I’ve I’m correct. I started a normal server in game, but I want my friend to be abel play it aswell. I need to do all these actions and begin a new game? So I loose the “normal server”?

    That would be a bummer

  2. thanks for posting this Didn't realize these scumbags were making us pay for the game seperately just to host a dedicated server on windows if you dont use steamcmd LOL wtf o.O

  3. Still can't get my server to show up, people can connect to it though if they are told the IP:port, just doesn't show on the list of servers in game. Also Server browser in steam says that its "not responding". I am running my server on ubuntu, and OMG if people have servers taking 15 mins to start up … and burn my server, just tested the server coming up from clicking enter to run the script and it took 4.31 … seconds. But anyways yeah still doesn't show

  4. can anyone answer if this is secure? we were port forwarding with my router with other devices before but they would be constantly bombarded by attempts to enter them from the outside. we had to shut off all the ports because of it. Does anyone know if the security on Valheim servers is any good (i assume not) and does the server get somehow routed through steam, and its security, based off of what im seeing in the video?

    Thanks!

  5. I have one single problem, when i start headless bat file it opens only one cmd window , loads some stuff then it says server connected and i can see it in steam servers and join the server through my local ip. The ports are open but valheim isnt available to my friends, as if i was running the dedicated server on my local network only.

    Followed multiple tutorials
    Installed steam cmd, made sure i have all ports open everywhere for udp and tcp in firewal and router, the external ip is correct
    Yet for my friends it shows the server is not responding, they can even see me in steam servers tab in friends that im playing something, but it doesnt show the game is valheim, only says server not responding.
    So i feel like there is a problem with the two cmd windows that should open up since for me only one opens.
    We tried setting up another server on my friends pc and for him its the same thing, only one cmd window opens up when he starts the headless server bat

    We spent a whole day on this and no luck…any ideas? We are starting to feel like we either missed something very obvious or there is a bug somewhere that needs to be fixed?

  6. Thanks for the video, but I have a problem. I open the server, the message "Game server connect" appears but when I open the game, the server is on the personal list, and when disconnecting from the world the server goes down, even with the cmd open.

    Sorry my english, a hug from Brazil.

  7. So yeah. I can't get it to run at all. It opens the two windows, sits there about 10 seconds, scrolls down and then closes. No error messages other than to say unused assets removed to save memory. I've added a name and password and all that. I've tried with the default state of the dat file. I've added the ports to windows/router firewall. In AND Out UDP and TCP rules. I've disabled the windows firewall completely and connected directly to my router. Run as admin. I've even just turned off WIFI. It crashes the same way every time. The last line is a long one starting with (Filename: C:buildslave…bindings.h line:35) and then it closes. Given that it does the same thing with the firewall completely off, it can't be forwarding can it? I'm at a loss.

  8. To who ever it may help.
    I changed the from 2356 to 2357 in the txt file. This I saw my server in the “community list” after I restarted the server.
    The default is text is 2356

  9. Yo man thanks so much for making this video I never heard of your till I seen this and now I'm going through checking out wat other videos and games u done a video on but deff new follower and gonna keep watching keep it up great video alot of help for me as I'm setting mine up as we speak but is there a way like with ark to run the dedicated server and play on the same pc if the hardware can handle it

Leave a Reply

Your email address will not be published. Required fields are marked *